PHP is among the most widely used general-purpose web programming languages. It’s highly popular since it is free software, which you can use to create responsive websites like social networking sites, online stores or e-learning websites instead of static HTML sites. A PHP module must be installed on the web server where a PHP website is hosted so that its PHP code can be interpreted. As there are no license charges for such a module and the language offers incalculable options for the Internet applications that you create, there’re 100s of millions of PHP sites. Besides, there are numerous PHP-based scripts, which you can use for your websites without the need to possess any coding knowledge. As there are different versions of PHP, you need to make sure that the same version that you used whilst creating your site is installed on the server as well.
PHP 4 and PHP 5 Support in Shared Hosting
In case you purchase a shared hosting package from us, you will never have to worry about whether or not your websites are compatible with the hosting platform, since several PHP versions are installed on our servers for the sake of your convenience. The Hepsia Control Panel will permit you to pick PHP 4, 5.2, 5.3, 5.4 or 5.5 with just one mouse click and in case you would like to change the current version, the update will be applied straight away. In this way, years of work on sites built with an older version of PHP won’t go down the drain. Our hosting platform will even allow you to use a different PHP version for each domain hosted in your account, which implies that you can run older and newer scripts simultaneously. Most web hosting providers on the market offer support for one, sometimes for two versions of PHP. Unlike them, we strongly think that you should be the one to choose the version that your very own websites will be using.
PHP 4 and PHP 5 Support in Semi-dedicated Hosting
If you’ve got a website created in a previous version of PHP and you have funneled time and energy into developing it, fixing safety holes and appending content, you’ll need to find a hosting service that can support it, since nearly all hosting vendors nowadays offer only the most recently published PHP version and give up the older versions. We, however, have decided to let you pick the version that your sites need. Our semi-dedicated hosting packages support multiple versions of PHP 5 as well as PHP 4, which goes to say that you’ll be able to use both newer and older scripts without forfeiting any custom modifications or misspending time and efforts trying to make your sites compatible with the web hosting platform. The version can be changed via the Hepsia hosting Control Panel and such an update will affect the entire semi-dedicated account, but you will also have the ability to pick a different version for each site that you host in your account using an .htaccess config file.